Three error messages after first download and import.

Discussion and help for Easy Save 3
Post Reply
Romi
Posts: 1
Joined: Fri May 17, 2019 2:48 pm

Three error messages after first download and import.

Post by Romi »

Hi

This is my first importing and installing of EasySave. I bought it on the May Sale on the 3 May 2019.

I am using Unity 2018.2.10f1 Personal.

I am getting the following three error messages:

Assets/Plugins/Easy Save 2/Editor/GUI/ES2EditorColumn.cs(194,22): error CS0117: `UnityEditor.PrefabUtility' does not contain a definition for `GetPrefabInstanceStatus'
Assets/Plugins/Easy Save 3/Editor/AddES3Prefab.cs(18,21): error CS0117: `UnityEditor.PrefabUtility' does not contain a definition for `GetPrefabInstanceStatus'
Assets/Plugins/Easy Save 3/Editor/ES3EditorUtility.cs(39,24): error CS0117: `UnityEditor.PrefabUtility' does not contain a definition for `IsPartOfPrefabAsset'

Thank you in advance for your help.

User avatar
Joel
Moodkie Staff
Posts: 4019
Joined: Wed Nov 07, 2012 10:32 pm

Re: Three error messages after first download and import.

Post by Joel »

Hi Romi,

It looks like the Asset Store is distributing the wrong version to users of Unity 2018.1 and 2018.2.

You can either update to Unity 2018.3, or if you PM me your invoice number I can send you the update manually.

I'm currently in the process of submitting a new update which will hopefully mean the right versions are sent to the right people.

All the best,
Joel
Joel @ Moodkie Interactive
Purchase Easy Save | Contact | Guides | Docs | Getting started

DMCH
Posts: 16
Joined: Mon Jun 16, 2014 2:26 pm

Re: Three error messages after first download and import.

Post by DMCH »

Hi,

I'm experiencing the same issue. I'd prefer to get the update than to update Unity. I can't find my invoice number (I purchased in 2013), but can I send you a screen grab of the unity page, which shows the purchase?

User avatar
Joel
Moodkie Staff
Posts: 4019
Joined: Wed Nov 07, 2012 10:32 pm

Re: Three error messages after first download and import.

Post by Joel »

Hi there,

If you PM me the screen grab that will be fine as I don't need to send you the entire package.

All the best,
Joel
Joel @ Moodkie Interactive
Purchase Easy Save | Contact | Guides | Docs | Getting started

ryuenplay
Posts: 2
Joined: Wed Jul 03, 2019 11:17 pm

Re: Three error messages after first download and import.

Post by ryuenplay »

Hi,
I am having the same issue as well, please send me the update too.. Thanks

User avatar
Joel
Moodkie Staff
Posts: 4019
Joined: Wed Nov 07, 2012 10:32 pm

Re: Three error messages after first download and import.

Post by Joel »

Hi there,

I've replied to your email. Note that downloading and updating from the Asset Store should fix your issue.

All the best,
Joel
Joel @ Moodkie Interactive
Purchase Easy Save | Contact | Guides | Docs | Getting started

Seiryu32
Posts: 23
Joined: Sun Sep 27, 2015 7:45 pm

Re: Three error messages after first download and import.

Post by Seiryu32 »

What do I do if I downloaded it from the Asset Store? I had to upgrade to Unity 2018.1.2 and got the same Unityeditor.prefabutility error that prevents me from using ES3 which I guess I need to use Auto-save in Unity 2018 or newer. I got the message that Auto-save for EasySave2 deprecated.

Post Reply