Working in unity editor but not on Android phone

Discussion and help for Easy Save 3
Post Reply
shashkes
Posts: 3
Joined: Sun Mar 22, 2020 4:53 am

Working in unity editor but not on Android phone

Post by shashkes »

This is the error log we get from the actual android phone:

2020-03-21 21:29:30.617 12130-12149/? E/Unity: NullReferenceException: The 'path' field of this ES3Settings is null, indicating that it was not possible to load the default settings from Resources. Please check that the ES3 Default Settings.prefab exists in Assets/Plugins/Resources/ES3/
at ES3Settings.get_FullPath () [0x00000] in <00000000000000000000000000000000>:0
at ES3Internal.ES3Stream.CreateStream (ES3Settings settings, ES3Internal.ES3FileMode fileMode) [0x00000] in <00000000000000000000000000000000>:0
at ES3Reader.Create (ES3Settings settings) [0x00000] in <00000000000000000000000000000000>:0
at ES3.Load[T] (System.String key, ES3Settings settings) [0x00000] in <00000000000000000000000000000000>:0
at LoadFavFromEasySave.LoadGameObjects () [0x00000] in <00000000000000000000000000000000>:0
at UnityEngine.Events.UnityAction.Invoke () [0x00000] in <00000000000000000000000000000000>:0
at UnityEngine.Events.UnityEvent.Invoke () [0x00000] in <00000000000000000000000000000000>:0
at UnityEngine.EventSystems.ExecuteEvents+EventFunctio

The ES3 Default Settings.prefab does indeed exist although has a slightly different location: Assets\Plugins\Easy Save 3\Resources\ES3
could this be the bug?
any other suggestions?

shashkes
Posts: 3
Joined: Sun Mar 22, 2020 4:53 am

Re: Working in unity editor but not on Android phone

Post by shashkes »

i changed the folder location and its still not working. any help would be greatly appreciated

User avatar
Joel
Moodkie Staff
Posts: 2755
Joined: Wed Nov 07, 2012 10:32 pm

Re: Working in unity editor but not on Android phone

Post by Joel »

Hi there,

I've moved your thread to the Easy Save 3 forum as your original was posted in the Easy Save 2 forum.

It looks like our error message needs updating, Assets/Plugins/Easy Save 3/Resources/ES3/ is the correct location.

If it's not providing anything as the path it suggests that there's a bug at Unity's end, as it indicates it didn't correctly deserialise the settings. Please could you let me know the version of Unity you're using, and also send a screenshot of the inspector for Assets/Plugins/Easy Save 3/Resources/ES3/ES3DefaultSettings.prefab so I can see what settings are currently set?

Also if you haven't done so already, ensure you're using the latest update of Easy Save which went live this week.

All the best,
Joel
Joel @ Moodkie Interactive
Twitter - Unity

shashkes
Posts: 3
Joined: Sun Mar 22, 2020 4:53 am

Re: Working in unity editor but not on Android phone

Post by shashkes »

Thanks for moving the thread. we are using unity 2019.3.1
attaching an image.
Attachments
easysave.png
easysave.png (232.6 KiB) Viewed 255 times

User avatar
Joel
Moodkie Staff
Posts: 2755
Joined: Wed Nov 07, 2012 10:32 pm

Re: Working in unity editor but not on Android phone

Post by Joel »

Hi there,

Unfortunately the attachment appears to be broken. Would you be able to upload the image to a service such as Imgur and post the link?

Also if you private message me your invoice number, I'll send over our latest update just in case the Asset Store is distributing the wrong version to you.

All the best,
Joel
Joel @ Moodkie Interactive
Twitter - Unity

Post Reply