Easy save doesnt work in build

Discussion and help for Easy Save 3

Easy save doesnt work in build

Postby h3kt0r_wwolf » Thu Mar 19, 2020 4:31 pm

So im using easy save 3 and i love you guys for making that it made my work very easy.
The problem that i have is that i cant use save and load features in my build its fine when i play the game in unity but in build it doesnt work. What can i do?
Thanks
h3kt0r_wwolf
 
Posts: 5
Joined: Thu Mar 19, 2020 4:29 pm

Re: Easy save doesnt work in build

Postby Joel » Thu Mar 19, 2020 4:46 pm

Hi there,

Are you using the latest update? There was a fix for a similar issue in that update.

All the best,
Joel
Joel @ Moodkie Interactive
Twitter - Unity - LinkedIn
User avatar
Joel
Moodkie Staff
 
Posts: 2688
Joined: Wed Nov 07, 2012 10:32 pm

Re: Easy save doesnt work in build

Postby h3kt0r_wwolf » Thu Mar 19, 2020 4:58 pm

Im using the latest version from asset store but it doesnt work :(
h3kt0r_wwolf
 
Posts: 5
Joined: Thu Mar 19, 2020 4:29 pm

Re: Easy save doesnt work in build

Postby Joel » Thu Mar 19, 2020 5:00 pm

Please could you check the console log for any errors? Easy Save will throw an exception to the console when any issues occur.

All the best,
Joel
Joel @ Moodkie Interactive
Twitter - Unity - LinkedIn
User avatar
Joel
Moodkie Staff
 
Posts: 2688
Joined: Wed Nov 07, 2012 10:32 pm

Re: Easy save doesnt work in build

Postby h3kt0r_wwolf » Thu Mar 19, 2020 5:03 pm

There is no error in console log.
It works fine in game and it saves and loads stuff really good but it doesnt work in build.
h3kt0r_wwolf
 
Posts: 5
Joined: Thu Mar 19, 2020 4:29 pm

Re: Easy save doesnt work in build

Postby h3kt0r_wwolf » Thu Mar 19, 2020 5:27 pm

So what should i do?
I saw the other post about it and they said a new version fixed it for them but i have the new version from assetstore and it doesnt work.
Help...
h3kt0r_wwolf
 
Posts: 5
Joined: Thu Mar 19, 2020 4:29 pm

Re: Easy save doesnt work in build

Postby Joel » Thu Mar 19, 2020 5:55 pm

Please could you put a Debug.Log call before and after your ES3 calls and check that the methods are being called?

Also have you accounted for the case where the app first loads when there is no save data?

Finally, you might want to check that you haven’t got ‘Fast but no exceptions’ set in the Player settings, as this will errors from being logged.

All the best,
Joel
Joel @ Moodkie Interactive
Twitter - Unity - LinkedIn
User avatar
Joel
Moodkie Staff
 
Posts: 2688
Joined: Wed Nov 07, 2012 10:32 pm

Re: Easy save doesnt work in build

Postby h3kt0r_wwolf » Thu Mar 19, 2020 6:27 pm

Im now considering to use easysave 2 cause i know that works and im new to unity and all this and im not underestanding what these fixes that you said are :(
Is there any setting in build menu that i have to change for easy save 3 to work in build?
Cause im sure that the code is working and there is no errors in console but it doesnt work in build.
The whole script that i used for save system with es3 doesnt work in build.
I attached a picture from the script that im using.
Attachments
PhotoPictureResizer_200319_215318444-567x1008.jpg
PhotoPictureResizer_200319_215318444-567x1008.jpg (126.11 KiB) Viewed 49 times
h3kt0r_wwolf
 
Posts: 5
Joined: Thu Mar 19, 2020 4:29 pm

Re: Easy save doesnt work in build

Postby Joel » Thu Mar 19, 2020 7:18 pm

Hi there,

Please could you private message me a basic project which replicates this so I can look into this further at my end?

All the best,
Joel
Joel @ Moodkie Interactive
Twitter - Unity - LinkedIn
User avatar
Joel
Moodkie Staff
 
Posts: 2688
Joined: Wed Nov 07, 2012 10:32 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 0 guests

cron